Jump to content


Photo

Mojmir's Build


  • Please log in to reply
256 replies to this topic

#1 pitkon

pitkon

    Administrator

  • Head Administrator
  • 1,206 posts
  • LocationAthens & Nafplio, Greece

Posted 10 March 2014 - 06:55 AM

latest is RC6:

Attached File  bbZero_install_1.18.0-rc6_mojmir.rar   22.73MB   3211 downloads

 

* fixed bb version detection in bbinterface_itunes

* added twapi 4.1.27 to bbTcl

 

----------------------------------------------------------------------------------------------------------------------------

older releases:

----------------------------------------------------------------------------------------------------------------------------

 

Attached File  bbZero_install_1.18.0rc5_mojmir.rar   19.1MB   696 downloads

RC5 changes:

* fixed compact mode

* bbfoomp unicode

* unicode for window captions, tooltips etc (bbleanbar) * bbsearch: fix of crash when reconfiguring while indexing

* zero initialization of styleitem

* bbsearch crash when lookup not created, but reloaded

 

 

 

RC4:

Attached File  bbZero_install_1.18.0_rc4.rar   19.13MB   26 downloads

RC4 changes:

 

* fixed wallpaper bug (bsetbg/bsetroot/.. ) under windows "susan boyle" 8.x

* merged bbSearch into main branch (new feature, may be bit unstable)

* fixed [inspath] in menu

* some menu related crash

* per core usage sysmonitor for bbinterface

* added /norestart for 1st redist on x64 platform (avoiding to restart twice)

* fix of bbstylemaker ui from user KillingSpree

* fix of bbLeanSkin titlebar actions from user Kaze

 

 

RC2:

Attached File  bbZero_1.18rc2.rar   18.7MB   568 downloads

RC2 changes:

* bbiconbox issues fixed

* alpha/saturation/hue ranges fixed

* other minor fixes

 


  • edom, AlterEgo, fireal and 19 others like this

#2 smersh2

smersh2

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 06 July 2014 - 12:00 PM

Hello:

 

Where I can get sources and build scripts ? - thx

 

AG



#3 pitkon

pitkon

    Administrator

  • Head Administrator
  • 1,206 posts
  • LocationAthens & Nafplio, Greece

Posted 06 July 2014 - 01:27 PM

Mojmir can provide you with sources. Do you think of helping along? That would be great :yes:



#4 diabol

diabol

    Lazyass

  • Moderators
  • 235 posts

Posted 06 July 2014 - 03:08 PM

Hello:

 

Where I can get sources and build scripts ? - thx

 

AG

 

The official repository is here: https://github.com/x...bclean-xzero450

Mojmir has posted the build instructions somewhere, too.

It basically goes like: Install Cmake-Gui, launch it, tell it where bb is, give it some output folder, configure it for visual studio (any version between 2010 and 2013 should be fine), generate the project and build in visual studio.

If VS comes up with a build error for the install target, you will have to change the installdir in the top-level CmakeList.txt, regenerate and try again.

It's a little unstable, but it works great once it does :)


  • pitkon likes this

#5 jjcastillo

jjcastillo

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 21 July 2014 - 09:05 PM

it's nice to see that blackbox is still somewhat under dev as nivenh and others or qwilk seem to not be updating bluebox or other derivative versions of blackbox for windows as much anymore ...it seems the last packaged update was/is bblean 1.17.1 in 32-bit and x64 flavors for windows 7 and really nothing along the guidelines or any ports created for windows 8/8.1 32-bit or 64-bit ....



#6 pitkon

pitkon

    Administrator

  • Head Administrator
  • 1,206 posts
  • LocationAthens & Nafplio, Greece

Posted 22 July 2014 - 06:38 AM

it's nice to see that blackbox is still somewhat under dev as nivenh and others or qwilk seem to not be updating bluebox or other derivative versions of blackbox for windows as much anymore ...it seems the last packaged update was/is bblean 1.17.1 in 32-bit and x64 flavors for windows 7 and really nothing along the guidelines or any ports created for windows 8/8.1 32-bit or 64-bit ....

So true! I use to be in touch with all creators of Blackbox/Bluebox/Xoblite and, yes, there is no updating. Bluebox is dead anyway and qwik does have some new Xob build (well, it was new some years back) but he is in no hurry to post it. You seem to be an old timer yourself, knowing nivenh and all :)



#7 xDemonessx

xDemonessx

    Member

  • Members
  • PipPipPip
  • 56 posts
  • LocationChicago

Posted 18 August 2014 - 04:56 AM

Glad to see some updates! I like seeing plugins being pulled over, but its such a downer not having unicode support.


  • pitkon likes this

#8 pitkon

pitkon

    Administrator

  • Head Administrator
  • 1,206 posts
  • LocationAthens & Nafplio, Greece

Posted 18 August 2014 - 06:35 AM

Glad to see some updates! I like seeing plugins being pulled over, but its such a downer not having unicode support.

Come to think of it, it would be great if you uploaded some of your famous Rainmeter bbi scripts :)



#9 mojmir

mojmir

    BB Developer

  • Moderators
  • 254 posts

Posted 18 August 2014 - 09:18 AM

unicode is probably the first thing to do after fixing most major bugs (gradients, aero)


  • pitkon likes this

#10 xDemonessx

xDemonessx

    Member

  • Members
  • PipPipPip
  • 56 posts
  • LocationChicago

Posted 18 August 2014 - 03:49 PM

unicode is probably the first thing to do after fixing most major bugs (gradients, aero)

 

Definitely, fixing visual issues and compatiblity first above all. It's nice enough to be able to spend time exploring plugins in any case!


  • pitkon likes this

#11 Heisenberg

Heisenberg

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 19 August 2014 - 02:39 PM

Anyone got this version working with Windows 8.1 update 1? When I run the program nothing happens and whenever I point to desktop my mouse pointer changes to the blue spinning wheel. Thanks in advance.



#12 mojmir

mojmir

    BB Developer

  • Moderators
  • 254 posts

Posted 19 August 2014 - 02:47 PM

i can try it later this evening at home. i have 8.1, but i am not sure about "update 1" though.



#13 Heisenberg

Heisenberg

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 19 August 2014 - 03:00 PM

Thank you mojmir! 
 
I got the diabol build working nicely. So don't waste your time, I'll keep trying your build and if I get any success I'll report back to you. Thanks again.


#14 Sudo Kai

Sudo Kai

    Deceitful

  • Members
  • Pip
  • 2 posts

Posted 19 September 2014 - 10:45 PM

Wooo i've been waiting on this like a kid looking lonely in a candy store window wanting a lollipop without money =P


  • pitkon likes this

#15 Enigma83

Enigma83

    Member

  • Members
  • PipPip
  • 25 posts

Posted 20 September 2014 - 05:04 PM

Maybe I'm wrong, but I think I've uncovered a conflict between Intel Graphics drivers and Mojmir's Blackbox builds (bbLean works fine but is too old). I was using BB on Windows 8.1, but the Wifi icon was nonfunctional, so I reinstalled 7. Everything went fine and BB continued working until I installed the Intel HD 4000 graphics drivers. I have an NVIDIA Optimus-enabled card, which means that I have 2 cards, one is Intel and the other is NVIDIA.

The main symptom seems to be that BB locks up when I right-click on the desktop and try to scroll the menus, particularly on the system/control menu. The mouse remains responsive, but I have to hit Ctrl-Alt-Del like 5+ times before the menu to choose Task Manager comes up. At this point BB is completely unusuable, Windows finally sends a messages saying that BB isnt responding and asks if I want to close it, which leaves me with a black screen.

 

I'll concede that any other program on my PC could be causing this, I'm going to reinstall 7 from scratch today, and then install only the minumum # of things needed (Windows Updates, Visual C redistributables, BB, and Intel/NVIDIA drivers). If I can keep it minimal then I can rule out other programs and safely conclude that there is a conflict between BB and Intel.

 

I've also tried 2 different versions of the Intel drivers, both with the same result. I would really like to keep BB, but this is unacceptable, for now it looks like I'll have to use Windows Explorer as my default shell. Having Intel drivers installed is a must, cant do without it, because NVIDIA's drivers are explicitly dependent on it, and without both of those I cant play games. I'm also interested in hearing whether anyone else has had a similar issue. My laptop model is Lenovo G700, is anyone is interested.

 

Thanks for any help!


  • Enigma83 likes this

#16 mojmir

mojmir

    BB Developer

  • Moderators
  • 254 posts

Posted 20 September 2014 - 06:10 PM

ugh.. nasty issue. and hard to reproduce on my side i guess.

maybe worth try to isolate the problem more. turn off all of plugins and see if it helps. at least we will know if it's in the core or plugins.



#17 Enigma83

Enigma83

    Member

  • Members
  • PipPip
  • 25 posts

Posted 20 September 2014 - 08:08 PM

I used BB load/unload function to "unload" all plugins. The issue still occurs. I find it implausible that an Intel graphics driver would be the problem. I had the exact same driver installed in Windows 8.1, but this never happened then, only in 7. But nevertheless, the issue occurred immediately after installing the driver. A friend of mine also has 7, Intel HD 4000 driver, and your latest BB build, yet he loves BB now and has never had issues with it, with the rare exception of BB crashing a few times. Is it possible that maybe the Visual C++ redustributables are interfering? What else can I do to diagnose this (error logs etc)? Thanks!

#18 mojmir

mojmir

    BB Developer

  • Moderators
  • 254 posts

Posted 20 September 2014 - 09:11 PM

nah, i do not expect the redistributables to be the cause (although almost anything is possible).

 

well the ideal approach would be to attach to the process with a debugger and see what is happening



#19 Enigma83

Enigma83

    Member

  • Members
  • PipPip
  • 25 posts

Posted 20 September 2014 - 09:21 PM

I'm still working on isolating the issues, by trying out some stuff in a virtual machine, and doing a fresh install of Windows with only the bare minimum stuff required. But all of this will really only help me to isolate what may/may not be the issue, it won't get to the root, and it won't get me the nitty gritty technical details of what is really going on. On the other hand, I've just barely gotten into programming, mostly Python and a little messing around with Visual Studio. I have virtually no experience with a debugger, but it would be interesting to attach to a process to at least see the output. Do you OllyDbg, Visual Studio, or something else? Perhaps the Windows Event/Error log might have some clues? Thanks!

#20 Enigma83

Enigma83

    Member

  • Members
  • PipPip
  • 25 posts

Posted 20 September 2014 - 10:59 PM

So.........I just finished reinstalling 7, made a full backup of the Windows partition immediately after logging in, then installed BB and the Intel driver. I set it as the default shell before logging out, then rebooted. At this point nothing else is installed, not even drivers or Windows Updates. The result is the same as before. BB otherwise acts normal, but I did notice that the freeze tends to occur after scrolling any menu that doesn't fit completely on the screen w/o having to use arrow keys/mouse to go down the list. Other menus cycle thru from top to bottom or bottom to top, so if I start at top and go all the way to the end, it goes back to the top. Not the case for the Control/System menu though, which is long. At that point it stops responding, I hit ctrl-alt-del, then I see the spinning blue windows mouse icon when I mouse over the BB menu, but not anywhere else on the screen. Eventually (if I don't terminate BB), Windows gives message stating that something caused BB to stop working, with the word "AppHang" (or maybe it was "AppCrash". I have also disabled User Account Control, always hated it. I also tried attaching to BB with OllyDbg (debugger) when logging in, but couldn't out how to save the output/log. Not much else I can think of at this point, thanks again!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users