Jump to content


Photo

help me make firefox play along nicely with bblean

bblean firefox

Best Answer rlv , 20 January 2014 - 08:38 PM

I had this session problem in latest Firefox too, downgrading to v25 "solves" it.

https://ftp.mozilla.....0/win32/en-US/

Go to the full post


  • Please log in to reply
29 replies to this topic

#1 innn

innn

    Member

  • Members
  • PipPip
  • 17 posts

Posted 20 January 2014 - 10:03 AM

Does  anyone still use firefox together with bblean. I tried bblean both 1.17 and 1.18 under windows 8.1(it happened under 8 too)

Basically everything else goes smoothly enter/exit fullscreen(F11), triggering web inspector debugger(F12), but I lose one feature that lets you undo the closing of a tab(Ctrl-Shift-T). No tab that's closed will come back ever. Also closing firefox will not restore tabs open from last time upon restarting.

I do not know why bblean screws the firefox profile.

Any  bblean version I'm in gives me this. I am reluctant to forsake firefox as I am very fond of pentadactyl addon.

This hiccup happens with and without the addon.

Happens with shortcuts as well with the same options clicked from the menus.

Can anyone confirm this?



#2 pitkon

pitkon

    Administrator

  • Head Administrator
  • 1,205 posts
  • LocationAthens & Nafplio, Greece

Posted 20 January 2014 - 10:08 AM

Have you included firefox.exe in the exclusions.rc list?



#3 innn

innn

    Member

  • Members
  • PipPip
  • 17 posts

Posted 20 January 2014 - 02:39 PM

Have you included firefox.exe in the exclusions.rc?

yes.

The stranger fact is that I disable bbleanskin not just toggle off but unload it and it still behaves like that so I assume it's bblean causing it.

Said behaviour is not present if I revert shell to explorer.



#4 pitkon

pitkon

    Administrator

  • Head Administrator
  • 1,205 posts
  • LocationAthens & Nafplio, Greece

Posted 20 January 2014 - 02:43 PM

yes.

The stranger fact is that I disable bbleanskin not just toggle off but unload it and it still behaves like that so I assume it's bblean causing it.

Said behaviour is not present if I revert shell to explorer.

Try to run Blackbox.exe on top of Explorer as shell. See if Firefox behaves the same. Also, have you noticed any difference with pentadactyl disabled?



#5 innn

innn

    Member

  • Members
  • PipPip
  • 17 posts

Posted 20 January 2014 - 04:45 PM

Try to run Blackbox.exe on top of Explorer as shell. See if Firefox behaves the same. Also, have you noticed any difference with pentadactyl disabled?

I've already said that pentadactyl is not the problem.

On top of explorer it works but running it that way defeats its purpose. Plus, if one uses Win+D to minimize all(show desktop) it loses the box and is just explorer.

It surely is a minor bug this interaction between  bblean and windows 8 . I can still choose bblean and live without being able to undo tabs in a browser. Still useful function I use it a lot but If that is something I am the only one using or wanting I understand it does not qualify for a change/update in the build.



#6 pitkon

pitkon

    Administrator

  • Head Administrator
  • 1,205 posts
  • LocationAthens & Nafplio, Greece

Posted 20 January 2014 - 04:52 PM

If firefox works flawlessly when BBLean runs on top of explorer, then it surely is a BBLean issue. All you can do, for the time being, is play with other branches until you find one that works with firefox. As for changes/updates, you never know. Maybe some developer faces the same problem...


  • innn likes this

#7 rlv

rlv

    Staff Member

  • Moderators
  • 19 posts

Posted 20 January 2014 - 08:38 PM   Best Answer

I had this session problem in latest Firefox too, downgrading to v25 "solves" it.

https://ftp.mozilla.....0/win32/en-US/


  • pitkon, Paz and innn like this

#8 innn

innn

    Member

  • Members
  • PipPip
  • 17 posts

Posted 21 January 2014 - 06:05 AM

I had this session problem in latest Firefox too, downgrading to v25 "solves" it.

https://ftp.mozilla.....0/win32/en-US/

wow, this is insane. it absolutely works with firefox 25.  thank you sooooo much.

 

Now is there any etiquette to mark the thread as SOLVED? in the title or ...?



#9 xDemonessx

xDemonessx

    Member

  • Members
  • PipPipPip
  • 56 posts
  • LocationChicago

Posted 21 January 2014 - 08:09 AM

The solution is to run Firefox in Vista Service Pack 2 compatibility mode. Currently on Win 7, bblean 1.18 x64, and Nightly (27.0a1) with no issue.

 

There is no reason to downgrade. Alternatively, you can run bblean at startup (not install as shell) and not encounter the close tab issue (as many have already said). WIN+D with Bbkeys also works for me no problem to minimize all windows.


  • Paz likes this

#10 rlv

rlv

    Staff Member

  • Moderators
  • 19 posts

Posted 21 January 2014 - 07:58 PM

Cool, compatibility mode works like a charm.

If anyone has issues with FF due to bbLeanSkin, I recommend trying Seamonkey - same features, more standard UI.


  • meanmechanics likes this

#11 innn

innn

    Member

  • Members
  • PipPip
  • 17 posts

Posted 22 January 2014 - 06:12 AM

The solution is to run Firefox in Vista Service Pack 2 compatibility mode. Currently on Win 7, bblean 1.18 x64, and Nightly (27.0a1) with no issue.

 

There is no reason to downgrade. Alternatively, you can run bblean at startup (not install as shell) and not encounter the close tab issue (as many have already said). WIN+D with Bbkeys also works for me no problem to minimize all windows.

Doesn't work for me in compatibility mode. Adobe Flash crashes. This is quite a dilemma as running an older version is posing security risks. I may try seamonkey. Thanks anyway. Firefox is a pain we all know where when it comes living with bblean under same roof



#12 xDemonessx

xDemonessx

    Member

  • Members
  • PipPipPip
  • 56 posts
  • LocationChicago

Posted 22 January 2014 - 07:22 AM

Doesn't work for me in compatibility mode. Adobe Flash crashes. This is quite a dilemma as running an older version is posing security risks. I may try seamonkey. Thanks anyway. Firefox is a pain we all know where when it comes living with bblean under same roof

This is an issue I've seen more often with Chrome. I would double check your Flash version, I'm running 11.7.700.224 with a few other plugins like Silverlight. Again this is on Nightly 27.0a1. :unsure:



#13 innn

innn

    Member

  • Members
  • PipPip
  • 17 posts

Posted 22 January 2014 - 11:28 AM

This is an issue I've seen more often with Chrome. I would double check your Flash version, I'm running 11.7.700.224 with a few other plugins like Silverlight. Again this is on Nightly 27.0a1. :unsure:

Flash is version 12.0.0.43. I have it set to update automatically.



#14 rlv

rlv

    Staff Member

  • Moderators
  • 19 posts

Posted 22 January 2014 - 05:20 PM

I tested latest FF (26) and Flash (12.0.0.43), no problems here. Like xDemonessx I'm also using Windows 7 though.



#15 innn

innn

    Member

  • Members
  • PipPip
  • 17 posts

Posted 25 January 2014 - 05:30 AM

I tested latest FF (26) and Flash (12.0.0.43), no problems here. Like xDemonessx I'm also using Windows 7 though.

Oh, that's nice but I have to live with my present system now which is 8.1 I am not reinstalling.



#16 thorfoc

thorfoc

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 25 January 2014 - 09:49 PM

Hi to all! Had the same problem with firefox for some time now, solved it yesterday thanks to this thread with compatibility mode (vista). I'm on win7x64, with bb4win_mod+7.11 (for now). Probably something changed in win8 with compatibility mode?



#17 cthu1hu

cthu1hu

    Styler

  • VIP Member
  • 93 posts

Posted 26 January 2014 - 07:12 AM

Installed BBLean the other day and just noticed I have this issue. I'm using 64bit Waterfox on Win7. I'd rather not downgrade Firefox either.

 

The other issue I have with Firefox, and bbleanskin, is titlebar flickering. I'd rather not exclude Firefox, and I hear that disabling "video acceleration when needed" in Windows' graphics preferences will remedy it, though I didn't try it. Excluding Firefox only worked when I included the classes, for some reason:

firefox.exexul.dll:MozillaHiddenWindowClassxul.dll:MozillaWindowClass

  • Paz likes this

#18 rlv

rlv

    Staff Member

  • Moderators
  • 19 posts

Posted 26 January 2014 - 09:54 AM

FF has a messy UI by default, but with some modifications it's possible to use bbLeanskin fine, without flickering.

 

What I've done:

- installed this extension: https://addons.mozil...-button-remove/

- enabled menu bar

 

Here's how mine looks like:

Posted Image


  • pitkon, Paz and xDemonessx like this

#19 cthu1hu

cthu1hu

    Styler

  • VIP Member
  • 93 posts

Posted 26 January 2014 - 01:30 PM

Thanks for that. I could tell the titlebar dropdown had something to do with it, as MS visual styles are also broken on the Firefox titlebar. I did remove it with that extension, but I didn't try enabling the menu.



#20 Paz

Paz

    Staff Member

  • Moderators
  • 108 posts

Posted 27 January 2014 - 01:22 AM

Very interesting tread, Thanks!  -- It might solve my flickering issues with Firefox as well .. I'll try your ideas for sure .






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users