Jump to content


Photo

Windows 8.1 64-bit - Changing wallpaper to something other than solid # colour messes up bblean

windows 8.1 wallpaper problems help

  • Please log in to reply
11 replies to this topic

#1 shrimpfarmer

shrimpfarmer

    Member

  • Members
  • PipPip
  • 18 posts

Posted 26 August 2014 - 03:29 PM

Allright, so I'm having a bit of problems applying a wallpaper for bblean in windows 8.1 64-bit (also I have dual monitors, and my goal is to apply a wallpaper exactly the same on both screens). When I'm trying to apply an actual wallpaper with the command:

blackbox.background.rootCommand: bsetroot -tile "F:BoxBilderBakgrundsbilderNaturSkyscapeclouds-airplane.jpg" -vdesk!(When I don't put "-vdesk" it gets pixelated!)

It looks perfect until I restart my computer. First it looks like this:

Posted Image

 

Then when I restart the computer it looks like this:

Posted Image

 

And it also writes this to"C:bbLeanpluginsbbLeanBarbbLeanBar.dll" (the bbLeanBar.2 stuff):

Posted Image

 

When I choose a solid background though, like so:

blackbox.background.rootCommand: bsetroot -solid #9cb8d4

it's completely fine.

 

All of the "blackbox.background.rootCommand" commands are in extensions.rc. I have no idea what the problem is and I can't find a solution. I'm suspecting it has something to do with my second bbLeanBar which I have for my second monitor "C:bbLeanpluginsbbLeanBar2bbLeanBar.dll".

 

It would be awesome if someone had a solution for this. Thanks.



#2 mojmir

mojmir

    BB Developer

  • Moderators
  • 254 posts

Posted 26 August 2014 - 04:35 PM

as soon as i finish this build i am working on with Pete, i'll try to look at the win8.x stuff



#3 Pico_No_Blackbox

Pico_No_Blackbox

    AHK Scripter

  • Members
  • PipPipPip
  • 53 posts

Posted 26 August 2014 - 05:36 PM

i use 

 

rootCommand: bsetroot -full c:bbzero_betawallswall3.jpg

 

and i have windows 8.1 and no problems.



#4 shrimpfarmer

shrimpfarmer

    Member

  • Members
  • PipPip
  • 18 posts

Posted 26 August 2014 - 05:46 PM

i use 

 

rootCommand: bsetroot -full c:bbzero_betawallswall3.jpg

 

and i have windows 8.1 and no problems.

What only rootCommand? Not "blackbox.background." before it? Do you put it in the style file or extensions.rc? Also not quotes for the path? It doesn't seem to work for me.



#5 shrimpfarmer

shrimpfarmer

    Member

  • Members
  • PipPip
  • 18 posts

Posted 26 August 2014 - 05:59 PM

Ah when I put:

blackbox.background.rootCommand: bsetroot -tile C:bbLeanwpclouds-airplane.jpg -vdesk

in extensions.rc it actually seems to work. Thanks Pico_No_Blackbox.



#6 shrimpfarmer

shrimpfarmer

    Member

  • Members
  • PipPip
  • 18 posts

Posted 26 August 2014 - 06:03 PM

But now when I put the old:

blackbox.background.rootCommand: bsetroot -tile "F:BoxBilderBakgrundsbilderNaturSkyscapeclouds-airplane.jpg" -vdesk

That didn't work before actually works now. I'm so confused



#7 shrimpfarmer

shrimpfarmer

    Member

  • Members
  • PipPip
  • 18 posts

Posted 26 August 2014 - 06:07 PM

Ok so I'm putting:

! -- background --rootCommand: bsetroot -tile C:bbLeanwpclouds-airplane.jpg -vdesk

In the style now, it seems to work, and hopefully it will not fuck up in the future.



#8 Pico_No_Blackbox

Pico_No_Blackbox

    AHK Scripter

  • Members
  • PipPipPip
  • 53 posts

Posted 26 August 2014 - 08:49 PM

What only rootCommand? Not "blackbox.background." before it? Do you put it in the style file or extensions.rc? Also not quotes for the path? It doesn't seem to work for me.

it is placed in the style rc only.

 

Posted Image



#9 shrimpfarmer

shrimpfarmer

    Member

  • Members
  • PipPip
  • 18 posts

Posted 26 August 2014 - 08:53 PM

it is placed in the style rc only.

 

Posted Image

Yeah that's what I did now aswell. Seems to work. Thanks man. I'll post here again if I'm experiencing some issues.


  • pitkon likes this

#10 hb860

hb860

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 27 August 2014 - 06:23 PM

In Windows 7, I used the following batch in style's rootCommand:

@echo offcd /d "%~dp0"setlocal EnableDelayedExpansionset r=%random%set n=0for %%f in (backgrounds*.*) do (   set /A n+=1   set "file[!n!]=%%f")set /A "rand=(n*%random%)/32768+1"set file=!file[%rand%]!echo %cd%%file%bsetroot.exe %cd%%file%

It sets the random wallpaper every time I start bblean.

However, in Windows 8.1 Update, it fails.

bsetroot works properly only if it was called from the rootCommand directly.

Any workaround will be appreciated.

Edit:

Wrong thread probably. I found this and I am not alone: http://blackbox4wind...ly-image/page-3


  • pitkon likes this

#11 mojmir

mojmir

    BB Developer

  • Moderators
  • 254 posts

Posted 29 August 2014 - 07:35 AM

we can look at it.. i have win 8 something at home. if i can reproduce it, i can debug it.

 

yeah, maybe we move in the other thread?


  • hb860 likes this

#12 pitkon

pitkon

    Administrator

  • Head Administrator
  • 1,210 posts
  • LocationAthens & Nafplio, Greece

Posted 29 August 2014 - 08:33 AM

we can look at it.. i have win 8 something at home. if i can reproduce it, i can debug it.

 

yeah, maybe we move in the other thread?

Move what to where? The whole thread or parts of it?







Also tagged with one or more of these keywords: windows 8.1, wallpaper, problems, help

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users