Jump to content


Photo

Crashing after right-click/context menu [bbZero] [Win 8.1 64x]

Crash context menu right click windows 8.1 bbzero

  • Please log in to reply
6 replies to this topic

#1 Flimmy

Flimmy

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 14 June 2016 - 01:29 PM

Okay so, I've been trying to to get Blackbox to work, and it does... until I try to right-click the desktop or processes on the bar, which results in a crash. I'm using the latest build posted here: http://blackbox4windows.com/index.php?/topic/123-mojmirs-build/

 

I recorded a small video to properly give an example of what I'm saying. I should note that on the video I am not using BB to replace the shell, however the same thing happens even if I do. I tried searching for a while and couldn't find anything. Anyone have any ideas as to what could be causing this? Thanks.

 

https://files.catbox.moe/ruqpou.mp4



#2 pitkon

pitkon

    Administrator

  • Head Administrator
  • 1,210 posts
  • LocationAthens & Nafplio, Greece

Posted 15 June 2016 - 06:13 AM

Okay so, I've been trying to to get Blackbox to work, and it does... until I try to right-click the desktop or processes on the bar, which results in a crash. I'm using the latest build posted here: http://blackbox4windows.com/index.php?/topic/123-mojmirs-build/

 

I recorded a small video to properly give an example of what I'm saying. I should note that on the video I am not using BB to replace the shell, however the same thing happens even if I do. I tried searching for a while and couldn't find anything. Anyone have any ideas as to what could be causing this? Thanks.

 

https://files.catbox.moe/ruqpou.mp4

No one has reported something like this before, afaik. What other processes are running at the same time?



#3 Seed_Value

Seed_Value

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 13 August 2016 - 02:03 PM

I have this issue to with win10. (BB run ok, but if right click mouse on desktop, in begin "indexing menus" BB crash)

 

Create new windows user without any programs in autostart.

login to new user and run bb.

If all ok, you can enable autostart for every programm.

 

BUT BEFORE try kill skype. And try start BB without skype (its help me, bb not crash)


  • pitkon likes this

#4 alpitrozzy

alpitrozzy

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 30 August 2016 - 04:46 PM

Same issue here. Also on 1.18 rc6, x64 8.1. Making a new user does not seem to help. This is all with BB as shell.

edit: Seems to work when not run as shell, actually. That's not viable for me though. Any ideas?
2: After disabling all plugins it no longer crashes. Not sure if it's connected or if I just got lucky. Re-enabling  blackboxbar works, too.



#5 pitkon

pitkon

    Administrator

  • Head Administrator
  • 1,210 posts
  • LocationAthens & Nafplio, Greece

Posted 31 August 2016 - 05:45 AM

Same issue here. Also on 1.18 rc6, x64 8.1. Making a new user does not seem to help. This is all with BB as shell.

edit: Seems to work when not run as shell, actually. That's not viable for me though. Any ideas?
2: After disabling all plugins it no longer crashes. Not sure if it's connected or if I just got lucky. Re-enabling  blackboxbar works, too.

Try to reload plugins one by one till you spot the culprit.



#6 alpitrozzy

alpitrozzy

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 31 August 2016 - 06:19 PM

Try to reload plugins one by one till you spot the culprit.

Couldn't quite reproduce it, so I tried running a fresh bbzero from another drive, and the crashes were there, even if I disabled every single plugin. Eventually (after several reboots, restarting explorer, un- and re-setting it as shell) it started working, but I couldn't figure out why. So I reinstalled it in (I believe) exactly the same way. Now it works right away after rebooting!
 
So I guess the lesson is that if it crashes, try reinstalling or re-setting as shell. Once it starts working properly, it doesn't seem to revert to crashing again, even after several reboots (not for the day or so that I've used it, anyway). Sorry I can't be of more help.
 
Also, having both bbmuse and bbpager enabled at the same time consistently makes blackbox crash on startup. Not sure if that's of interest; I don't use either.

  • pitkon likes this

#7 pitkon

pitkon

    Administrator

  • Head Administrator
  • 1,210 posts
  • LocationAthens & Nafplio, Greece

Posted 01 September 2016 - 04:36 PM

 

Couldn't quite reproduce it, so I tried running a fresh bbzero from another drive, and the crashes were there, even if I disabled every single plugin. Eventually (after several reboots, restarting explorer, un- and re-setting it as shell) it started working, but I couldn't figure out why. So I reinstalled it in (I believe) exactly the same way. Now it works right away after rebooting!
 
So I guess the lesson is that if it crashes, try reinstalling or re-setting as shell. Once it starts working properly, it doesn't seem to revert to crashing again, even after several reboots (not for the day or so that I've used it, anyway). Sorry I can't be of more help.
 
Also, having both bbmuse and bbpager enabled at the same time consistently makes blackbox crash on startup. Not sure if that's of interest; I don't use either.

 

That's solid info for anyone who faces such issues, thanks.

BBMuse is quite old anyway and practically replaced by bbinterface functions.







Also tagged with one or more of these keywords: Crash, context menu, right click, windows, 8.1, bbzero

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users